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/A CAUTION /A ATENCION
Do not climb onto the printer. No se suba encima de la impresora.
/A ACHTUNG /A ATTENZIONE
Niemals auf den Drucker steigen. Non salire sulla
/A ATTENTION AFE®E
Ne montez pas sur ' i FFOLICREBUNIE,
BEEES IR KE. /A CUIDADO AER
}55533&%’/&{4&%K%W&HUEEE}JE&“EE*J:o Nao subir em cima da impressora. WPBEEELE.

2 (¢ )
ANEE A\ WARNUNG
[BERCEN Teile in Bewegung.
FPUEEIFRNTE, Halten Sie Finger und andere
Korperteile auf Abstand.
AES /\ AVERTISSEMENT
HEREERMUER . Piéces mobiles dangereuses. 7
FHNESRAERR. Eloignez les doigts et autres
parties du corps.

A\ WARNING /\ADVERTENCIA /J\‘B‘E'—:E'
Hazardous moving parts. Partes peligrosas en movimiento. TE]m.
Keep fingers and other body Por favor, mantengase alejado.
parts away.

A\ ATENCAO A\ AVVERTENZA .

Pegas moveis perigosas, Attenzione parti in movimento.
mantenha os dedos e outras Tenere le dita e altre parti del
partes do corpo afastadas. corpo lontane. P S
<)
8 /A CAUTION

3 AT, faa T Y

SE] -
*EI N E”TZIS; N \ z'ﬁ'zﬁ Take care not to let the liquids come into contact with
your eyes or onto your skin, BrEES | R RIE.
. otherwise inflammation can result. S EHMBSRAEARE BRI R L
China only /N ACHTUNG
Vermeiden Sie den Kontakt der Fliissigkeiten mit .
Augen und Haut, sonst konnen diese gereizt werden. Chlna Only
4 — /A ATTENTION
CAUTION " N " P N
‘Moving platen, T-shirt tray and covers can cause bodily injury. Keep hands off platen while printing Veullllez ane pas Ila'sse" ces liquides étre en contact
A ACHTUNG avec les yeux ou la peau, ) )
Druckplatte, T-Shirt-Ablage und Abdeckungen konnen krperliche Verletzungen verursachen. car ceci pourrait entrainer une inflammation.
Halten Sie die Hander von der Auflage wahrend des Druckvorganges fern.
/A ATTENTION /\ ATENCION
Déplacement du plateau, chargeur T-shirt et couvercle peut blesser le corps. - — -
Garder les mains éloignées lors de limpression. Tome el cuidado para no permitir que los liquidos
A\ ATENCION toquen los ojos ni en la piel,
M do la pl la bandeja de tay biert: d herid: l. i id
R o o :{;gfmgﬁfg}fﬁﬁegzﬁ” iertas pueden causar una herida personal de otro modo inflamacién puede resultar.
A ATTENZIONE
Tavoletta mobile, il ripiano per la T-shirt ed il carter potrebbero causare infortuni. A ATTENZION E
Tenere le mani lontane dalla tavoletta durante la stampa. Evitare il contatto di questi I|qU|d\ con gll occhi e con
AFEE h ol ;
TITURTYvYRUAEEN (—EQMICFE>EH, INET D, DIBIPETSTUNSFERIE, la pe”e pOIChé potrebbero creare infiammazioni.
3 3 =
] AZE AEE
/\ CUIDADO REZRITTEED S D
Movimento do ciindro, prato de impressao e tampas podem causar lesoes corporais. 1V IREDREFNBEPEECHIRNELSICTEIE,
/\ CUIDADO

Tome cuidado para n&o deixar que os liquidos entrem
em contato com os olhos ou a pele, caso contrario,
poderé ocorrer inflamagéo.
NT, KINETBTEN BB, HERSERS, 2SR, /
. SRS THBN/—&RBTIIE, ELNRTRIR § DG, BACES.

A DANGER A PELIGRO

Un voltage non adapte provoque| Un voltaje inadecuado puede
des blessures. Eteindre provocar las heridas. Apagar el
t linterrupteur et attendre 5 interruptor principal y esperar 5
before opening this cover.| bevor sie diese abdeckung Gfinen. [minutes avantdouvrir le capot. | minutos antes de abrir esta cuberta

>PS<
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/\ CAUTION

A\ VORSICHT

©0

Bitte trinken Sie nicht die
Flussigkeiten, da die Gefahr von
Erbrechen und Durchfall besteht.

Do not drink the liquids under
any circumstances, as they can
cause vomiting and diarrhea.
Take care not {o let the hquwds
come into contact with

e{es or ontoyour skin,
otherwise inflammation can

AATTE NTIO N

Keep the liquids outof  No tome los liquidos en cualquier |
ihe reach of chidr caso, como pueden causar

Vermeiden Sie den Kortald der
Flussigkeiten mit Augen und
Haut, sonst kénnen diese gereizt
werden. Halten Sie di
Flssigkeiten von Kindern forn.

/\ ATENCION

vomitar y diarrea. Tome el cuidadol
para no permitir que los liquidos.

Ne pas avaler les liquides

foquen los ojos i en la piel, de

A\ ATTENZIONE

Non bere per nessun motivo i
liquidi poiché possono causare
'vomito e diarrea.

Evitare il contatto di questi
liquidi con gli occhi e con la
pelle poiche potrebbero creare

Infiammazioni. FRAK G HES| &
Conservare i liquidi lontano &5 &%%Tﬁ*ﬂi?ﬂ!ﬁﬂilaﬂit-
dalla portata dei bambini ARELE L ETEM R

ﬁjﬁﬁ%ﬂﬂ!?—?ﬂﬁﬂi 1%% H' 2

A\ CUIDADO

beba os liquidos sob nenhumal
circunsténcia, pois eles podem
causar vémitos e diarréia. Tome
cuidado para nao deixar que os

W Deposite in compiiance with you local
reguiations.
‘Gebrauchte es gemat értichen Richtinien

isorgen.
. Jetez conformément a a reglementation
locale en vigueur.

eseche siguiendo I normativa local,
maltire in conformita alle normative locall

liquidos entrem em contaio com os
apele.

inflamagao.Manterha os liquidos
[fora do alcance das criancas.

oo
WO Al TRRLTUEE L,
R AR
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/\ CAUTION

A\ VORSICHT

/\ ATTENZIONE AE®E

Bitte trinken Sie nicht die

©0

Do not drink the liquids under any
circumstances, as. (hey can cause
vomiting and diarrhea.

Take care not (o let the liquids come
into contact with your eyes or onto
your skin, otherwise inflammation

can result, Keep the liquids out of the

reach of children.

Flussigkeiten, da die Gefahr von
Erbrechen und Durchfall besteht.
Vermeiden Sie den Kontakt der
Flassigkeiten mit Augen und
Haut, sonst kbnnen diese gereizt
werden. Halten Sie die
Flassigkeiten von Kindern fern.

Non bere per nessun mofivo i liquidi
poiché possono causare vomnito e diarrea.
Evitare il conlatlo di questi liquidi con gli
occhi e con la pelle poiché potrebbero
creare infiammazioni. Conservare | liquidi
lontano dalla portata dei bambini.

THR-H5U T DTEEN DB D 1 VT 18
EORBBERE RN & MEERC
OB DD 1 > D78 E DRI
EPEEILHDMRBVLSICTEDIE, F
HOFOBHNRNEIBICEL L,

A\ CUIDADO A E &

Nao beba os liquidos sob nenhuma
ois eles podem causar

/\ATTENTION

\ATENCION

Ne pas avaler les liquides d'aucune
maniére, car ceci pourrait entrainer
vomissements et diarthée. Veuillez a
ne pas laisser ces liquides tre en
contact avec les yeux ou la peau, car
ceci pourrait entrainer une
inflammation. Maintenez les liquides

No tome los liquidos en cualquier
caso, como pueden causar vomitar
y diarrea. Tome el cuidado para no
permitir que los liquidos toquen los
ojos ni enla piel, de otro modo
inflamacion puede resultar.
Mantenga los liquidos fuera del

vomitos e diarréia. Tome cuidado para nao 5 ﬁ

deixar que os liquidos entrem em contato | ETEE S35 . IKIt. H2 XA H BE R
com os olhos ou a pele, caso contrario, R BRI RES | R AT BB B SRR

podera ocorrer inflamagao. Mantenha os 5. o - 0
ek e Call (v a T L L T 2

W Deposite in compliance with your local regulations. Ml Gebrauchte es gemaB ortiichen Richtlinien entsorgen.

W etez conformément a la reglementation locale en vigueur. B Deseche siguiendo la normativa local
8 Smalire n conformia e normative ol B Deposit om conformidade com osregulamentos ocai,

A R

CAUTION

/N VORSICHT

cresoronio o
olherweo fammation can

he rech of childrbr

n Etbrechen un
mmmau LR Varmeiden S den
tak:

i tiken Sie neht de Fussigferien.

 dor Flissigholon mi Augon und
laut, Sonst konnen diese gere
perdenHaten Sl die Filsigketen von

/\ATENCION

/A ATTENTION

cocf pourrai entrainer vomissements o1 ciarihée.
Voullr s ne pas aisser os lides dre
J65 yeux ou a peu.
[bourrait entrainer e inlartmation. Msmlenez
les iauides hors de portée des enfant

ATTENZIONE

Mon bere et nesean oo It poicne
mito o diarrea. Evi

[Ne pas avaerTs Tuides davcune manTere car |

e l Gontatlo d ques | FE£XE 51

[No tome Tos liquidos en cualquier caso, |
omo pueden causar vomitar y diarrea.
ara no permilir Que os

liquidos toguen (05 ojos ni en l2 piel, de
ol

oifo modo
antena oz qucos fuea delacance
o i

oF
g
e

fromiiunenn e o o s oeore verwendenvor ] (1400 con g1 Oceh s oan ' pele poché pavebbso | 17244
daucune maniere, car ceci otro modo inflamacion fuede o oA oSN Uit van /S anice 5e [l [cieare imiammazion Concervare 19y ionane |35 2, 00T Dgisnt Lo ECE Ly
pourcateniraner resutar. Mantenga os Iquidos N 2 Usoprima ama )25 [l (e porat oetbamoin,
Yomissements et diarrhee. uera del alcance de ninos. e Sarevan’ o, Lo o by O s OST 4 UK_-441500 285
Veuillez a ne pas laisser ces - /\ CUIDADO
hquvdes &tre en contact avec 31 ARA Gl Souior) "KIEREW Wate basad Mo TS 1 % ;.52 ;ebﬁap%i Tt 52 e s
B B ool [SoE soRE e Tt | @0
Dlammation CORIMERE BN ) HTE : e ‘Baders ocarror infaragdo. Mantenha L
Maimencz o5 s horsdo.[IIEfE o2, <772 DRI ELLﬁMMEM’rw:N S 75 o oancs das chances.
i EPRBCHABNELSICTBTE, oS sesans i % 26 SierEgamannen o s W.B'I!,“ n‘::\‘wnﬂumnwawn i i e el e
portée des enfant; ; BhdIETICE iii 0 B e o aromen movermee vro. R0 I 2 ER s o

hors de portée des enfants, alcance de nifios. HEDEBCU > THBELTES LN, W R RL R -

12 A &

BICATChRBICOL L,

AEE

MFHENRFHBRI L,

A\ CAUTION

Lubricating grease may cause Inflammation to eye and skin.

brother

T1Y—2 ;E&%Eﬁgsggﬁilt ggg;‘é;’ig Wear protective glasses and gloves
il BB TFHLEET S, B un;amggléﬁé\nﬁt. Swallowing grease can cause diarrhoea and vomiting.
GREASE BNBNIE, HOAA- Do not swallow.

13 /N CAUTION

Do not drink the liquids under any
circumstances,as they can cause vomitin
and diarrhea Take care not to let the liquids
come into contact with your eyes or onto your
skin,otherwise inflammation can result.Keep
the liquids out of the reach of children.

©0
A\ VORSICHT

Bitte trinken Sie nicht Flussigkeiten, da die Gefahr von
Erbrechen und Durchfall besteht. Vermeiden Sie den Kontakt
der Flussigkeiten mit Augen und Haut, sonst kénnen diese
gereizt werden. Halten Sie die Flusswgkellen von Kindern fern.

A\ ATTENTION

Ne pas avaler les liquides d'aucune maniére, car ceci pourrait
entrainer vomissements et diarrhée. Veuillez a ne pas laisser
ces liquides étre en contact avec les yeux ou la peau, car ceci
pourrait entrainer une inflammation. Maintenez les liquides
hors de portée des enfants.

/\ ATENCION

No tome los liquidos en cualquier caso, como pueden causar
vomitar y diarrea. Tome el cuidado para no permitir que los
liquidos toguen los ojos ni en la piel, de otro modo
inflamacion puede resultar. Mantenga los liquidos fuera del
alcance de nifios.

/A ATTENZIONE

Non bere per nessun motivo i liquidi poiché possono causare
vomito e diarrea. Evitare il contatto di questi liquidi con gli
occhi e con la pelle poiché potrebbero creare infiammazioni.
Conservare i liquidi lontano dalla portata dei bambini.

A\ CUIDADO

Né&o beba os liquidos sob nenhuma circunsténcia, pois eles
podem causar vomitos e diarréia. Tome cuidado para ndo
deixar que os liquidos entrem em contato com os olhos ou a
pele, caso contrario, podera ocorrer inflamagéo.

Mantenha os liquidos fora do alcance das criangas.

AERB
THBOLTDEREMNH D, 1 VI REDBRBERFE BN &,
REZRCITTREENH D, 1 VI REDFEENBPEBCHH
BVEDICTDIEFHOFOBHRVECDICELZ L,

A E
(&)

GRS KIS X B BHBERAL.

BRIRES | RRE S ERMBERAL A CE
ERAPEKRL X Lo BB L E T AR RIS .

W Deposite in compliance with your local regulations.

W Gebrauchte es geman ortlichen Richtlinien entsorgen.

Jetez conformément a la reglementation locale en vigueur.

W Deseche siguiendo la normativa local. M Smaltire in conformita alle normative locali.
M Deposite em conformidade com os regulamentos locais.
WO ERICH->TRELTR S B HRRYMERER.
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MR TEINURS, T I SCAHL 2R .

[E#]

o IHFTEWUG, TEFTENmIERG A RIARYE T B AT Bk
e’ 7-2-1. FTENMIHER AT (FIAFTERSR)  >>P. 1857
w”7-2-2. FTENLIEE DOP. 1877
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H B G FT B K

QUEFTENERERI T4 2 Fi, "] Brother 7 " A" I FLA N FHARE " s TEARIE A I S N IR Y o
AN Brother F=SnHIRFFR, (HZANRAE A AAOR R, AR 3 MR R —Rh, DRG&
nTROFTENZE SR, ARF0ER T A HA N R PP AP B,

§F Brother 7= i i

MR R e GUVAL
GTX Graphics Lab Graphics Lab {# 15 B3
A8 P G Ath S FHAZ bt

AR R o GUAL
CoreIDRAW(2018/2019) "5-3-1. ffif] CorelDRAW i >>P.63"
Adobe Photoshop(CC2020/CC2019) "5-3-2. {# A Adobe Photoshop i} >>P.70"
Adobe lllustrator(CC2020/CC2019) "5-3-3. fifif] Adobe lllustrator i >>P.75"

(%]

o IFRIESN PRIV E, & BN R R R s B AT 2R A
o i RGB=(254,254,254)iiik }'RGB=254", RGB=(255,255,255)ii.ik }y"RGB=255".
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QAT BNt

B (380

GTX PRO #TEIHLA RGB AT EIHL.

Z i RGB faU G S s, HRHEFEE G 155 E N sSRGB(sRGB IEC61966-2.1).
(%]

e {iiH Adobe I} Corel IR FIFEFF IS, CMYK Bt B AT R o B I % .

o  HIffitE RGB#F, WIS{#F Adobe RGB &5 E4MNII IR, IFRIREST A I AT

FTERHERR

BB A T BN R (R 4RFK RS AR T, FRRfA ST ENHERR

SR A FE SC R " Brother GTX PRO FileOutput™ T ENFLIRENFR AT BN«
[&%]

o EWNTIEMECEITENREG, #UCEH GTX PRO TEINLEE N PC [ B NERIAFTEINL].

SRk ea ik y e
PR A F il SR e U A o SR QU T DA, K RGB=255 {4 & B (" Ab 2, AN i 55 .
TEEAE A b ST RN A B IR, 1E N RGB=254.
(%]
o RIERIHFYT, RGB=255 [MALH AR, &Lk E.

ARXP Cft

A FH SCA T " Brother GTX PRO FileOutput™$T ENFLBRENFEFE LL ARXP K8 3017
AR CL ARXP #X0RAE, AT DARAST BN ()5 B AR & .
[Z%]
o MY, EEHATEINLIRE AL " Brother GTX PRO FileOutput". 5 is & 5 FIFE & HI[Print to file]Hs 4t et
WSROI R A2 AN arxp,  HUAT A TCIdE e A B
o BN GTX BJEHI ARX4 SCfF, w]ffH GTX PRO #TE1,
o GT-541/GT-782/ GT-3 RFIMTEIEHETGZE T GTX PRO FTHI.
o WFIE PC $&HIHMR BT EMHLIRSIFE T, WILES R R A A 2. FTEVRTEHAST EDHLIRSI AR T A1 &
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5-2. {¥H Brother GTX PRO FileOutput &iAfTEN##E ({X Macintosh)

R AT ENBCE R A7 2L

f&H"Brother GTX PRO FileOutput"fTEFHLRHT ENEHR CRAF B SCAFI, 1E 7R B)"GTX PRO FileViewer"[FRRA& N AT
FEAEB"GTX PRO FileViewer" PR T, KB FEAR, ToIEIRAT

[Z%]

o IRIERHREY, WREARREER. WERXES) “GTX PRO FileViewer Ja FPRES T T-

iR
7 FEBIERAN,
s

[Z%]
e jEII"Brother GTX PRO FileOutput" #7344 2538 5 Windows HLAH ] .

FIBITENEHE

{ Ff"Brother GTX PRO FileOutput"] ENHLERAF T N, 15 1EIE LN IR A2 EIML.
(%]
o RIEITENEHENIS IS Windows AR

(1) XA "Brother GTX PRO FileOutput"T EIHLER A4 & 44 " arxp" RS 1
(2) "GTXPRO FileViewer"J533)j, siilKIEZHTEIF]HIKIE
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5-3. fEHHEALN AR

5-3-1. f§iF] CorelDRAW I}

B, TEHPATRATEAE.
o FiE
o ITEIRSY
TEARE T BT DL A
o QIEEFTENEHE (ARXP 31
o SRR B R
o HHHAIE
o KHAIEITH) RGB=255 £y RGB=254

[=5]
o AHLHHEE A H CorelDRAW 2018/2019. ifEid CorelDRAW 2019 i BH &/~ Hih .

B EHERE
(1) MR %R Tools] >[Color Management].
(2) [Color Management Settings]i#47 A F 1% & .

e [RGB profile]: [SRGB IEC61966-2.1]
e  [Primary color mode]: [RGB]
¢ [Rendering intent]: [Relative colorimetric]

Color Management Settings X
Default
A
Preset: | Custom v ﬂ
RGB profile: | (Default) sSRGB IEC61966-2.1 >
CMYK profile: (Default) U.5. Web Coated (SWOP) v2 -
Grayscale profile: | (Default) Dot Gain 20% -
Primary color mode: | RGB -

Rendering intent: | Relative colorimetric v

Color conversion

Color engine:  Microsoft ICM CMM hd

Preserve pure black
+ Map gray to CMYK black

? oK Cancel
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ITENRF
(1) WSz iR File]>[Print]
(2) ¥[Printer]i & ~"Brother GTX PRO"L"Brother GTX PRO FileOutput" [T —Mf, sidi[Apply], JCHI[Print]
TEAE
(%]

o ¥[Printer] % & N"Brother GTX PRO "I}, T ENINHT B4 RS E4T EIAL.
¥[Printer] 4 & A/"Brother GTX PRO FileOutput"itf, FTEPIFTENEELL ARXP SCEHRAT -

Print X
General Color Composite Layout Prepress PostScript No Issues
Destination
Printer; Brother GTX pro - | e
Orientation: | Match orientation (Letter, Portrait) -
Status:
Location:
Comment: Single File -
Print range Copies
@ Current document Documents Number of copies: 1
Current page Selection
1 I
LG
Print as bitmap: 300 dpi
Print style: CorelDRAW Defaults - Saye As...

? Print Preview » Print Cancel

(3) MEEfrhikELayout]>[Page Layout].
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(4) [Page Sizeli#H TN NXE.

e [Size]: [Custom]

e [Width]: 355.6 =X
e [Height]: 406.4 =X
o ITEIRYITIA]: HhI)

(%]

K FE LA B B B OIS o BB ORRHERT 14%16 RIS . =7"5-4-1. R >>P.83"

Document Options

General
Page Size
Layout
Background
Guidelines
Grid

Rulers

Save

? Save as Default...

® Page size Label presets

Size and orientation

Sizefl§ Custom - = ]
Widthf§ 355.6 O o millimeters  ~
Heightlj 406.4 0 o

Apply size to current page only
+/| Show page border
Add Page Frame
Rendering resolution: ~ | dpi
Bleed: |4.0

Show bleed area

OK
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BUATENSHE (ARXP 3214
LA ARXP 4% 30 UG EUE AN T ETBEE N B AT N R AE
AR ARXP SO AT LAHEAT EA TR #4E
o ATLLRFEHMEHE AT BN BV B R R AR
o ARIAER: PC M USB f7fifi & ELHEATEN.
(%]
o ARXP XUHTCESEEHE . S EHEEER R R
o BN HIREFHERPrint to file]fi & R RETCETE R SO SO AL B AN f 4% . I RIAT ENHLIRSIFE/ 7" Brother GTX
PRO FileOutput",
o NWNHIRER EALFIT N AOEEHEN ="6-6-2. AN HIFEFFACAITENEE >>P.142"

(1)  MEEAE RIS File]>[Print].
(2) 4TH[Colorlbras, FATLATFBE.

e i%&H[Document color]
e [Color conversions]: "Brother GTX PRO"E%"Brother GTX PRO FileOutput"
e [Color profile]: [sRGB IEC61966-2.1]
e [Rendering intent]: [Relative colorimetric]
Print X
General ~ Color ~ Composite  Layout  Prepress  1lssue

Color: ® Composite

Separations

Settings: ® Document color

Color proof
Color conversions: Brother GTX pro FileOutput -
Color profile: sRGB IEC61966-2.1 b

+| Preserve pure black

Rendering intent: Relative colerimetric b

0 The color settings and preview available in this dialog box are set for the Windows
Graphic device printer that you selected on the General tab.

? Print Preview » Print Cancel Apply

(3) FTH[Generallt52%, M[Printer] ik 4 H F"Brother GTX PRO FileOutput".

(%]
o HHEERZRK[Printer]iX & " Brother GTX PRO ", $TENEME &% EFTEINL.
B8 E TR AI[Printer] i3 & 4"Brother GTX PRO FileOutput"ff, #TEI%E L ARXP SCEH#-E

(4) fE[Preferences] & BT EINLIRBIFE T . ="5-4. W EFTEINLIKEFEY >>P.81"
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(5) % F[Print]XxHEHERI[OK] G, sl FAHEHE. AdiERA7]

(%]
o ATRERTELJ Lo EREIIA].
94 Brother GTX pro File OutputRTAmiE u] X
H5E: MG_1404 o0 7.0
[=LEE[ER 13/02/2020 15:06 ’ A
ERRT: 14x16
HEELE: ya+aeng
= 5
.2 3 7
FIEMR@E: x 10
BEHES: 400 %
HAEHNER: off
HEMESERET: off
...
PEMmE: 0.06 cc 8.0 —
aEmE: 0.20 cc 100% J i : s : ! 600%
$IER: 13k ' ' ' ' ' '
BRE [T weomvk =] I B
iy mH wRE I - |

(6) FREMRIFAEINDCIFA] [RAFIARXP 31t

A8k FR SR R R v R AR A

(1) IZREH e, £ CorelDRAW H I A SCf4"GT_Colors. xml"F1"GT_Tshirts. xml"{f47 2 PC .
(2) MEEAL %R Window] >[Color Palettes]>[Open Palette].

(3) EFEAFZ"GT_Colors.xml"FI"GT_Tshirts.xml",

(%]
o B/ HKS. Pantone BN EA LN A, 75 i A T N AT BEAN A o
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BN
(1) MRk FE[Bitmaps]>[Convert To Bitmap].
(2) #[Color mode]i% & N[RGB Color].
(%]
o EHIAGIMERITEIRS, Ki[Anti-aliasing]ft) & EHERGHL .
Convert To Bitmap X

Resolution: |300 - | dpi

Colormode:  |RGB Color (24-bit) -

Options
~| Anti-aliasing
+| Transparent background

Uncompressed file size: 3.33 MB

7 0K Cancel

[Z%]
o RIEMITENHLBRSIFE T B F BRI, [Page Layout] -t AT REAE M[Settings from printer].
S GEA MR T FE[Page Layout] - B s s B A s
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BT EN B s
B E ) RGB=255 ##: 5 RGB=254
RGB=255 iR A NiE (. 18 RGB=255 I35/ AN i .
FTENA @R, 151%8 RGB=255 [1IX 1315 #: y RGB=254.
T E DL 5 T B .
(1)  MSEEArhik[Effects]>[Adjust]>[Replace Colors].
(2) Aid[OId color]ft) Tz, fr[Replace Colors]i% & & RGB=255.

Replace Colors X

2o
(3) HFEERTT 2K [New color]iX By RGB=254.
(4) ¥[Rangel#&BEAN"", ASd[OKIZ4.
Replace Colors X

Options: Ignore grayscale
Single destination coll
Difference Between Colors
Hue: o |2
Saturation:; 0 -
Lightness: o |2
Rang; £

[%£]
o REHEEN, ERKIRLSEIOE NN RGB=254,
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5-3-2. {#F] Adobe Photoshop K}

#ifid Photoshop $47 LA 4.
o PiINE
VAR T ZE AT DL T A
o GUERFTENEHE (ARXP (1)
o AR
o J"RGB=255"# 1 4"RGB=254"

[Z%]
o EEHNCMYK I, i AR H= ik Image] >[Model#44ih RGB % (sRGB). #id Sk s~ H1¥[Image]>[Adjustments] 1]
SEHYREREME, SCEETEUIRSIE I E RS (57'5-4-9. WEER >>Po4") FifE K.
o AHLHHEFEH Photoshop CC2020/CC2019. iffiid Photoshop CC2020 5 H G RIHI [ »

BERE
(1) MR %FEEdit]>[Color Settings].

(2) [Color Settings]ifTLL Nk HE.

[Working Spaces]
¢ [RGB]: [sRGB IEC61966-2.1]

[Conversion Options]
e [Engine]: [Adobe(ACE)]
e [Intent]: [Relative Colorimetric]

[Color Management Policies]
e [RGB]: [Convert to Working RGB]
e [CMYK]: [Convertto Working CMYK]
e [Gray]: [Convertto Working Gray]
e [Profile Mismatches]: i%H[Ask When Opening]. i%H[Ask When Pasting]
e [Missing Profiles]: i%H'[Ask When Opening]

Color Settings X

Settings:  Custom
Working Spaces Conversion Options
GB: sRGB IEC61966-2.1 Enagi Adobe (ACE)
Japan Coler 2011 Coated Intent:  Relative Colorimetric
Dot Gain 15% Use Black Point Compensation =
ot: Dot Gain 15% 2 Use Dither (8-bit/channel images)

3 Compensate for Scene-referred Profiles 2 Preview

Advanced Controls
nvert to Working CMYK Desaturate Monitor Colors By:
Convert to Working Gray Blend RGB Colors Using Gamma:
< When Opening &3 Ask When Pasting 2 Blend Text Colors Using Gamma: 1.45

s Ask When Opening

d applications
color.

Description
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BIEATENHHE (ARXP U1
LA ARXP g Ot UG BAE AN T BN A B E T N ORAT
AR ARXP SR R ABEAT B TR 14
o ALK EUGEERAITEN B BB B AR ORAE
o ARIAER: PC M USB f7fifi & ELHEATEN.
(%]
o ARXP ffTirgmin g . TEF Sk EUGEHR R NS -
o ENF SR FAER [Print to file]4s 4 AT RETGIEFE i U RS g A AT e g . VEE AT ERHLIRBNAE T " Brother GTX
PRO FileOutput".
o MWNFHFER EEMFT BN ACE BRI ="6-6-2. MRLFHFRT KIESTEN SR >>P.142"
(1) MEEAR R ESFile] >[Print]l. PC —fsEF HI4T EIHL A" Brother GTX PRO"E"Brother GTX PRO FileOutput"itf,
AR A FRAR Rt
(2) BHATLLTEHE.
e  [Color Handling]: [Printer Manages Colors]
¢ [Rendering Intent]: [Relative Colorimetric]

Photoshop Print Settings X

Printer Setup
Printer:  Brother GTX-4 FileOutput

Copies: 1 Print Settings...

Layout: n Fi

~ Color Management

Printer Profile:
Normal Printing

Rendering Intent:  Relative Colorimetric ~

»  Description

~ Position and Size

LEPTEes

(3) MI[Printer]i&F; 44 F"Brother GTX PRO FileOutput”,
(%]
o Kf[Printer]i% & N"Brother GTX PRO "I}, FTEN¥EAI%EEITEIHL.
¥s[Printer]i5 & A"Brother GTX PRO FileOutput"ftf, #TEdE LA ARXP SCAH#-AE

(4) {E[Print Settings] % BT EINLIKSFLT . ="5-4. X EITEINLIKEIREF >>P.81"
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QT BN dfs
(5) #& TIPrintl)5 Eos LA FXHEHE. s fRAF].
(%]
o TTRERZLATBHRAIN A

BF Brother GTX pro File OutputFTEE O x
5 IMG_1404
EMRRiE: 13/02/2020 15:06
EERT: 14x16
SHERAE: ¥e+aane
= 5
i 3
IR iE: x10
aEnER: 400 %
HEEHNES: off
HEMESREREID: off
.-
FEME: 0.06 cc
EEnE: 0.20 cc 100% f——————— 600%
fTED: 13 ' ' ' ' ' '
8rE 1 W+CMYK | [T E&#HR
— e =

(6) FREIRAFAEILIFA], [RAFIARXP 3Cft.
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A58 FH S PR A AR R Al

(1) F=MEH TR, & Photoshop HHIiE i SC4H"GT_Colors_T.ase"frf7 4 PC H.
(2) MSEHARREEWindow] >[Swatches].

(3) M=, IR,

Swatches

RGB=254

(%]
o B/ HKS. Pantone BN EA LR A, 75 U imi e T N AT BEAN A o
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BT BN s
# RGB=255 £ #: 4 RGB=254 i}
RGB=255 {5 iE I . 8 RGB=255 I3 /0 AN HijH 52
ITENE T, 5% RGB=255 [1I[X 8 ) ##: & RGB=254 .
T LA 75t T B 4
(1) ESEERrLayer] >[New Adjustment Layer] >[Selective Color]f1]i: 5 K2 .
(2) BAEERE N 20%I 53 [OK].

MNew Layer s

Selective Color 1

Use Previous Layer to Create Clipping Mask

Cancel
Color:  [%]None

Mode: Normal Opacity: 2 i]

(3) 7E[Selective Color]+#HTLA F ik E .
e [Colors]: [Whites]
e [Black]: 1%
e i%&rf[Absolute]

Magents:

[Z%]
o W LA, ¥ RGB=255 #ifiy RGB=254 [{1777%, 1¥[Color mode]’’J[RGB Color]fI[8 bit] I FH .
e  liT Photoshop ¥ RGB=255 # & A RGB=254 [{jzh{F 30" SolidWhite.atn"fESZ 4+ ("5-5-2. K"RGB=255"& 14
"RGB=254" ({X Photoshop) >>P.97"RGB=255"##:4"RGB=254" ({{ Photoshop) >>P.97"RGB=255"¥{f’A"RGB=254" ({{
Photoshop) >>P.109"). KT 75, 1EZH Photoshop HIFER.
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5-3-3. f#F Adobe lllustrator i

I llustrator AT LA R EEAE .
o FifaitE
o JTIRHTCM
TR 75 AT DL R ERAE
o QIEITENEHE (ARXP 3
o SRR I R

[Z%]
o EEREMREERATESTENERIN, EUREUE RS I, TEIHT L M.
- JEBIRTIER PC — R KT ENFL3E B N "Brother GTX PRO"={"Brother GTX PRO FileOutput"s
- J#id"Brother GTX PRO FileOutput"+] ENHLERSNFE 4 SO @ T A .
o B HNCMYKIH, i K432\ Photoshop, iBid 3 Hi i f)[Image] >[Mode] #4454y RGB 4. % (sRGB). 734+, i 2 A Photoshop
DA P g S BB T EPH LIRS IAR P R B (='54-9. R EER >>P.94") fiREIE.
o AHLHHEE{E llustrator CC2020/CC2019. @it llustrator CC2020 i B EonHi i -
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Bt E
(1)  MSZEFHIEFR[Edit] >[Color Settings].
(2) sit[More Options].

(3) TP T B I R [OK].
o [Settings]: [Custom]
[Working Spaces]
e [RGB]: [sRGB IEC61966-2.1]
[Color Management Policies]
e [RGB]: [Convert to Working Space]
e [CMYK]: [Convertto Working Space]
e [Profile Mismatches]: i%H[Ask When Opening]. i%H[Ask When Pasting]
e  [Missing profiles]: i%&H[Ask When Opening]
[Conversion Options]
e [Engine]: [Adobe(ACE)]
e [Intent]: [Relative Colorimetric]

Color Settings

t color. To

Working S
RGB: sRGB IEC61966-2.1

CMYK: U.S. Web Coated (SWOP) v2

Color Management Policies
Convert to Working Space
(: Convert to Working Space

s: B Ask When Opening [ Ask When Pasting
Profiles: B Ask When Opening

Conversion Options
Engine: Adobe (ACE)
Intent:  Relative Colorimetric

Use Black Point Compensation

‘D Hold the cursor over a setting for additional information.
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TR
(1) BEEHO.

e [Width]: 355.6 =X
e [Height]: 406.4 =X
e [Orientation]: [
e [Color mode]: [RGB]

[2%]
o RS ENEHIEIGT . (57"5-4-1. TS >>P83") LR NARIER) 14x16 [EARATRT

More Settings

Name: Untitled-1
Profile: [Custom]

Number of Artboards: J 1

Size: [Custom]

Width: 355.6 mm Units:  Millimeters

Height: 406.4 mm Orientation: [g] [&]

Top lottol Left Righ
-~ - -~ . ~
0 mm 0 mm o

o ~

0 mm
w Advanced
Color Mode: | RGB
Raster Effects: High (300 ppi)

) Mode: Default

Templates... Create Document
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BIEITENESE (ARXP X
DL ARXP &2 UG BE AN T Ei5 B B E T EDEdE R AT
A ARXP SCIFJG AT BAEAT L R #RAE
o TTLLEEUGEEEANFT BN BB B — AN SRR
o TILUREER: PC M USB 13k B8 BT EL.
[2%#]
o ARXP SUEIEORIEIEIZ. WA EURERARAE A -
o IERLFRHRLTHER I[Pt to file]Hi & AT R R SCIF RSO AL BRI B 44 . 15T ENHLIREN T Brother GTX
PRO FileOutput".
o SRR BT EHL R SR 6-6-2. LAY RIEFTENSAE >>P.142"

(1) Meespipik[File] >[Print]>[Color Management].
(2) HATLLTEE.

e  [Document Profile]: [sRGB IEC61966-2.1]

e [Color Handling]: [Let lllustrator determine colors]

e  [Printer Profile]: [sRGB IEC61966-2.1]
e [Rendering Intent]: [Relative Colorimetric]

Print

Print Preset: Custom

Printer: Brother GTX pro FleOutput

General Color Management

Marks and Bleed
Qutput
Graphics

GB IEC61966-2.1
e — et Tllustrator determine colors
file: sRGB IEC61966-2.1

:| Relative Colorimetric

Description
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(3) M[Printer]hi% 34441 H Fi"Brother GTX PRO FileOutput”,
(%]
o Kf[Printer]i% & N"Brother GTX PRO "I}, FTENEEAI%EEITEIHL.
#[Printer] % & 4"Brother GTX PRO FileOutput"itf, FTEIE L ARXP AR

(4) 7r[Advanced] & BATENHLIRBSIEE R . ="5-4. W BEITEINLIREIAET >>P.81"

[EE]
o Adobe lllustrator I, I8k FIFE AU R T B[O EARE A FRIARTEAAS BB AR ST AT BT EDREAE R IS, AT RETGIAIER
BE BUE RS E .
(5) #% FI[Print]5 Sos LA FXHFHE. midilfRAF].
(%]
o HREFREJL BRI TE .

& Brother GTX pro File OutpuFTSEE o X
#HaE: MG_1404 . 07 : 7.0
Bl id: 13/02/2020 15:06 : ~
EERT: 14x16
SRR @ +aRnk

= 5

B 3 .

FTENRTEl: x10

HEREE: 400 %
FRRHNEE: Off
FERESHEEIT: off

4.
PERE: 0.06 cc L i
BEHE: 0.20 cc 100% J ‘ ‘ ' ! 600%
FIED: 13k U
BRE 1 WeMYK x| [T GER4R
i H L N = |

(6) FREIRAFAEIDCIFA], [RAFIARXP 3Cff

79



QAT BNt

A RS A Hh R AR

(1) FMEH RN, B llustrator I (HCCA"GT_Colors_T.ase"{#474 PC .
(2) MSEHARREEWindow] >[Swatches].

(3) A=, &#FET£H[Open Swatch Library].

(4) i%&FF[Other Library].

Swatches

(5) 7E[Open]imi [ HiE&F 14 "GT_Colors_T.ase".
(%]
o iZfafi 5 Photoshop Fil CorelDRAW ANJ], 7 EAERRIT A SCIFI 4%
B2, f#H llustratorCC i, ilid AR 75BN E bz, BRAUR BN AN AT LA A Bh R,
METERER ETNES, W TIRREE]

Gt T Add to Swatches
» Sort by Name
| A APW 4 4 A PP ﬂ.i Sort by Kind
id UV 4 4 d d d AV 4 d d 4 P - S
AWV 4 a W AWAVL 4 VL L . W Show Find Field
AP PP : d 4 AW4 4 4 AV4 4 4 4 )
P 194 JEV 404 4 4 4 4 a W A Small Thumbnail View
4 4 AWACA 4 4 4 d 4 AV 4 474 4 4°4 4 Medium Thumbnail View
P A A AT
Large Thumbnail View
Small List View
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5-4. WEITHNEEF

[Z%]

e GTXPRO #TEINLIKENFE T RGB=(255,255,255)1F A" B " Kb #E, At v a8 . AREME A B G ssd T e sl B e USR5
W E A RGB=(254,254,254).

o KTHGMBHIE, EEESNAREFIAHNT ("5-3. MM HET >>P.63") s AR,

(1) RSN REFFRHTEEER,  SoRITELARARE A4 T BN B XA

== fIEEER X

Exme ETAE

FEiRR~T: 14x16 e IS E
BB FE+asns v
Bt @ 8% [@]=1-H:EF: 3
BEiHEiGE: 1 03 5 7 9
ot | [ s
1 2 3 4 5
JEHE: I | 3
FTEMAiE: | 1 EEEE 400 %
[ Ba=ms#TED
ClaeEssRiTen ’_
Caesmi4Ten ’_
OfREfSeEeTnEm
[(I%2ee8y 8-S EEEITED TEEiTEE

e
i SN
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QT BN dfs
(2) AT EIHLIRENRE T H9T B i BN TR REREA T DT R B
rh[VRANBEE], PTRCEBE A OmE]. [ERRE] [FREFTE.
(%]
o IRIE[HSEE. FFRENNEAR, iR s E BAR.
o TENSIEHE MRV MBS BN EE R, BEhRbnTEE, AR,
o RTHEWEIHIWY, ESRLEHET.

Brother GTX pro SEHHEE=ES X
BRSNS
[Jiz8Ae&.: B oreen (0,199,0) =H)...
B EHERES: @@EE O 45
1 2
I | 1
012345678910
BERENHIREE: I | 2
EFiZE
0 10 20 30 20
e | [ s
k1.4 I | 5
RbLE: I | 5
PRTH
S5l m o g
#e: i [0
qe: i [0
e l | 0
Ba: f [ o
[ &reTen
ER:
T EBRBARCGE(E s R EHIE -
AL

(3) ELEHE ST
(%]
e M"GTXPRO File Viewer":H$T 7T ARXP SCHJG 2 IR A B B F1E .
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5-4-1. EFERRT

MBS e 1R BT B Rl R AR R
(%]
o BTSRRI

BETH fEHT AR )

[16x21] 16x21 JEAR 406.4 ZKx533.4 =K

[16x18] 16%18 JEHR 406.4 Z£Kx457.2 2K

[14%16] 14x16 AR 355.6 ©£Kx406.4 K
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o MRHE[FEDL: | [REMNESHMAITERE, [FTEE: | RAGmSE. KA.
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o RGB=255{FA"EMIM" CAMTENBIEL) A2,
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o WERFEBUNER, HUCESLRITH.

Brother GTX pro EEaE=S X
BEARHE

[igBeeE: Bl green (0,199,0) el

i EeRRE: @i% Oits
i 2
I 1
012 3 4567 89 W0

AR BEAMIEE: [ 2

I
I
I

FEPE

54-3-2-10 12345
it i [ o
AN=E I ’T
e i KN
e j KB
(] aTEn

O
gnmamﬁma WA THESRATENER . cmdafi@m=lnER  RiEtame

@ ] s

94



QAT BNt

5-4-10. HEEL T

sty (T BN ] R HEHE A R [PRA i L) om DR P ] BB
D] T, WTUARE [FE: 114t 10at: J[BA: 1.
AJFE-5~+5 1) 11 ZL T N R (R

(%]

o VSR TUAROCR AR, UTOREEE A .

wWEIH 1481
(Bt ] WEE AR . FEIE, BASmRRE S, WREME, BIASRA.
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5-5. f{#FSER% M (Useful Tools)

e AT CATE VAR (] sl 7 i A 4T B B A P PRS2 FH R T BN
"Useful Tools" 2 7E 1 FH PC i"Brother GTX PRO Tools"H.
KFHTEMEANE, 1SRG,

5-5-1. fEHAER

N HREFE 7 IBCA TR B
e  Adobe Photoshop/lllustrator: [GT_Colors_T.ase |
e  CorelDRAW: [GT_Colors.xml|. [GT_Tshirts.xml]
ARVEN, WAREMAEFRI (575-3. EHHARRTFES >OP. 637D &R AR RIFEDD.
(%]
o TEBRABCE TR EIHLIRAAR PN P T PRI RN, BAE Bl | S EUE BN (R C RIS, {5 FH R €4 . (CorelDRAW
E— T EMR AR A A, EE S 2 4D

5-5-2. #"RGB=255"%#%:4"RGB=254" ({{ Photoshop)

iliid Photoshop ¥ RGB=255 ##:h RGB=254 I {fiH.

(1) M"Useful Tools" ¥t "SolidWhite.atn", 2/ i ()3~ e PC s At
(2) M Photoshop )z s HRiE[Window] > [Action file].

(3) =, fIHTH.

(4) iEid[Load Actions], iE#f PC Hi {47 (1"SolidWhite.atn".

(%]
RFIMESCHIIER 7, 152G Photoshop FF5 .
e {X[Color mode]N[RGB Color]fI[8 bit] 7T LA A" SolidWhite.atn" .
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5-5-3. HHIABEEAEAR

VENBEREATHN AL .

VLB BT LIRS AR P 1 B O T ENEE (ARXP SCIF), R4 = i R R A
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(1) 15 "Useful Tools"H i i (301144, I T EEHE. BoA DL TR A
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GT_Oranges.pdf
GT_Reds.pdf
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(2) WEITEOWLIKENFET, BUEHTEREdRE.
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o RTHTEWURIMERF I ETE ="5-4. WEFTEINIIRNFET >>P.81"
o QIEATENEUE =5-3. bR YT >>P.63"
(3) K EIEMHTENEHE KX BATEMHLIFATED . ="6. FA4TED >>P.103"
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o IHHHATENRAIF B TENHLIRE R T BLE
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N /

/

AR
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(1) M"Useful Tools" T 45 & AR IRIRIA% RS 1) ARXP SCH (i, Grid14x16.arxp).
(2) RelPRE T ENEI A& AT BN L
(3) AVEE T, EEAEARIGAR AT ERA% .

(%]
o ITEVE, WEHTATEARERZIE, FThas.

5-5-5. FTEIM=EE

WEITHWIREN PR I, WEREE.

15 M"Useful Tools"H F4EdE, FHATH (=76, FEASTE >>P.103"), FEHNE .

(%]

o MR TMEEEMEAR, WERNAEEREENAR. ENFEMTHEENAEREME, NEaIETEEdE.

o MEEEATEIEIEA 4 Fh. IEES ST EINIIREN[2 (kT BN B PR s T B

(1) M"Useful Tools"H.15"Ink Volume SinglePrint.arxp”. "Ink Volume DoublePrint1.arxp". "Ink Volume
DoublePrint2.arxp". "Ink Volume DoublePrint3.arxp"tF ({HTEE—4, TaHdE.

(2) FEIEOERITENIHATED,

(3) VEFHMTENRCR, IFREEITENNLASIRE P . JiE.

B CAProgram Files ther\GTX pro Tools\Usefulink Volume SinglePrintang - o X
5 Ink Volume SinglePrint .o T v 7.0
BEE: 20/12/2017 17:25 !!Itlllili =
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BRI fret-)
FapRE: 10 0
2%4TEN:
RN 8 SIIETEN: off
...
AR 041 cc 80—,
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5-5-6. {TENFEDEIE RRMCRAERSR

BEEATEMNUIREIRE P HIRE: T, B AR A
B M"Useful Tools" FEEE, HAeITEEDRARISE, JFASREEN AL, RMIERE., B 0.
[Z%]
o HTETCEGH T ML ERHTITED. =6, FEAYTED >>P.103"
o AUE T MBEBMITAR, SHAEREEBAR. SR e ARG R B, SRS AT .
(1) M"Useful Tools" 7 #.:f7"Highlight-Mask Check at MW1.zip"gk"Highlight-Mask Check at MW2.zip", R,
(%]
o RN SRR B E N RI2] R SN
NSRRI, FRET R

(2) A% zip SO, oD T B .

e  "HighlightCheckPattern"

o FKHEDLHI"MaskCheckPattern"
(3) #TEN"HighlightCheckPattern”, ittt BiH.
(4) FTENEAEEDE R E{E F"MaskCheckPattern", %5 FEIUE Y 15 B AH .

(5) IEHAITENRCR, FFARATENLIEIRE PR RGBS JH(E.

& CAGTX pro\HighlightCheckPattern MW1.arxp — [m] X
EEA: Highlight Check MW1 o e
H R E: 09/04/2018 01:05 '
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B FE+EEihe

=t 1

B 3 .
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FIREHEIEE: off
FEE ST off
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5-5-7. WA A A

RIS HH NS )2 75 1A o

(1) M"Useful Tools"#::"FIRING CHK COLOR arxp"s{"FIRING CHK WHITE.arxp", i .
(2) FEEIOEEATEIHIIFTEN

(3) EEHHATENRCR, AT ENRE LR 15 IERE

G C:\Program Files ther\GTX pro Tools\Usefu\FIRING CHK COLOR.anp - o x
=2 FIRING CHK COLOR 2% u Ll
501wyt e
Badia: 17/09/2015 00:05 Bt . G
- . .
ERRT: 14x16
THEER R EinE
FEmnes: 10 0
ZRATED: 1
F2BEY B SIERITEN: off
..
FEnE: 0.08 cc 80—,
TED: 13 100% || 600%
SERETENL
.. ki

5-5-8. FHIANESGHA I E

TN EAR IS 15 1A

(1) M"Useful Tools"#1;"FEEDING PATTERN(1).arxp", F#E%dE.
(2) BEIEAIESFTEHLIHFTER.

(3) EMHINITEIRE, #iNERGHA B IERIRE.

B C:\Program Files ther\GTX pro Tools\Usefu\FEEDING PATTERN(1).arxp - u] X
s FEEDING PATTERN(1) o o u v
B 13/12/2015 18:52
ERRT: 14x16
TBEER {RFEBE

E S o 10 0
ZITEN: 1
FEE B SBETEL off
...

FEBE: 0.09 cc S

1TER: 13 100% | 600%
SR ETERL
... ik
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(1)  M"Useful Tools"#.#7"ALIGN CHK.arxp", T #%iR .

(2) KB A& AT EIH LT RN

(3) IETINFTENRCR, NS A EFR RN B RS IEMILE.

G CAProgram Files the\GTX pro Tools\Useful ALIGN CHK.arxp - o X
55 ALIGN CHK oo 2 U g
BWHA: 19/04/2017 16:31 -
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CorelDRAW

(1)  MSEEBR RS [File]>[Print].

(2) FTHF[Colorts2s, HATLANXE.
e %" [Document color]
e  [Color conversions]: "Brother GTX PRO"g%"Brother GTX PRO FileOutput"
o [Color profile]: [sRGB IEC61966-2.1]
e [Rendering intent]: [Relative colorimetric]
Print X
General  Color = Composite  Llayout  Prepress 1 lssue

Color: ® Composite

Separations

Settings: @ Document color

Color proof
Color conversions: Brother GTX pro FileOutput -
Color profile: sRGB IEC61966-2.1 -

+| Preserve pure black

Rendering intent: Relative colorimetric -

0 The color settings and preview available in this dialog box are set for the Windows
Graphic device printer that you selected on the General tab.

? Print Preview ﬁ Print Cancel Apply

(3) FTH[Generallt5%%, M[Printer]#i%$"Brother GTX PRO ",
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~  Color Management
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(1) K USB fififiastdi NAFAE AR AT THI 1) USB fEfifiastdi .
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